Studies down

It is something wrong with the Studies this days?


It looks that is possible to access to the studies already created but not to add any new chapters or create a new one.

Restarted the server yesterday, which seems like it fixed it for now. But I still don't know what exactly caused this, so it will probably happen again, if it does please mention it here, because I need more info (how were you trying to create the new chapter - empty/sfen/kif/game; study id; etc.) to find the cause.


I tried to added to an existing study an edit position, then a mesasage of error appeared so I tried to add the edit position to a new study but it did not work either.

So finally I checked if it was possible to have access to the other studies from my profile page and that did work.


Fixed some related bugs, that could maybe be the cause of what happened, but I didn't manage to replicate the issue locally, so I'm not sure.
In any case now it works, I will be checking this post regularly so if the issue reappears please let me know here or on github.

On a related note, any suggestions on a nice way to fully backup an entire study? I was thinking of writing a quick script to download each individual chapter using the API, but wonder if I'm missing an easier button click somewhere. I've got so much I don't want to lose in a couple of my studies and I need to do a better job of protecting them. Thanks!

'<studyId>.kif' will put kif of every chapter in the study into one file. There is no button for this because multiple 'kifs' inside one 'kif' is not really valid (I think). I might change this someday to just put all the kif files separately into a zip file.
I take backups of the db daily, so if the db goes completely south, I will just roll back to a version at most a day old.